Jump to content
X2Community Forums

Search the Community

Showing results for tags 'database'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Information
    • Announcements
  • Support
    • Community Support
    • Installation Help
    • Feature Requests
    • Bug Reports
    • X2CRM Premium Support
  • Discussion
    • General Discussion
    • Development
    • X2 Webcasts
    • Web Lead Capture
    • Sales Force Automation
    • Customer Service
    • Marketing
    • Administration
    • Products & Quotes
  • International
    • Internationalization (I18N)
    • Language Packs
    • Deutsche
    • Portuguese
    • Francais
    • Russian
    • Español
    • Chinese

Categories

  • X2Engine Source
  • Internationalization (I18N) Packs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 12 results

  1. I have attempted both a fresh install of the latest stable release as well as updating from 6.0 to 6.5. I am able to do a fresh install of 6.0 without issue, however not with 6.5. My host is Inmotion Hosting. Below is a copy of the error output: Exception: "A database change failed to apply: CREATE TABLE `x2_sessions_token` ( `id` char(128) NOT NULL, `user` varchar(255) DEFAULT NULL, `lastUpdated` bigint(20) DEFAULT NULL, `IP` varchar(40) NOT NULL, `status` tinyint(4) NOT NULL DEFAULT '0', PRIMARY KEY (`id`)) ENGINE=InnoDB DEFAULT CHARSET=utf8;. The error message given was: SQLSTATE[42S01]:
  2. In a custom module (Mymodule), I need to create a custom field (c_custom) for a blob. The "Multiple Line Text Area" offered in X2Studio is too small of a datatype. I need to change the datatype in the db. Easy enough. But what files in X2CRM do I need to change to keep things in sync? (I am not familiar with the file structure of x2crm except what is given in the docs.) And, can I just change the type in the db and the appropriate file of x2crm, or is there code to run to have the file update the database for me? Thanks in advance.
  3. I did a fresh install last night (for testing purposes). It works fine for a few hours. Make a few test social posts, change the theme to black, upload a logo, walk away. Checked again today and now getting this error on login (nothing has changed with the install, and I have reproduced this problem 3x, each time happening on a fresh install, community version 6.9) Error Code: 500 Error Message: CDbCommand failed to execute the SQL statement: SQLSTATE[22007]: Invalid datetime format: 1292 Truncated incorrect DOUBLE value: '' Stack Trace: [click to toggle display] CDbException in /var/www/x2e
  4. Currently in the x2 database in the "x2_actions" table. There is no "CreatedBy" field. Is it located somewhere else? missing? to be added? Please see the attached image.
  5. This post cannot be displayed because it is in a password protected forum. Enter Password
  6. Hey Guys, Hope you can help i've recently noticed that since i upgraded my x2engine that the delete function has disappeared from the front end. I can't delete anything the red cross for deleting has disappeared on every page & i am ADMIN so i should have access to everything. I have attached an image to show you how it looks now. Could anyone help me out as its a hassle having to delete entries from the database itself as we want the system to go live soon. Kind Regards Mohamed Hussein
  7. Hey Guys, I was wondering if i can get any help. So i'm using the Open Source version of X2Engine but i've come accross this problem which is stopping me form being able to continue with my work. I've added a few things extra to the system however now for some reason it will not let me access any of the data when i click on the data inside the module. Could someone take a look at this & help me fix this as soon as. Thanks Below i've included the Stack Trace so you can see what error im getting: Error Code: 500 Error Message: Invalid argument supplied for foreach() Stack Tra
  8. This post cannot be displayed because it is in a password protected forum. Enter Password
  9. Hello, how can I change the Database Password? I had to reset it since i forgot the sql database password so I need to reenter it in x2engine. thanks
  10. Hi, I've run the system requirements test and all is fine. I've created a database and I can login no problems via mySQLadmin. However while running the install script for X2CRM, I am not able to connect to the database. When testing the connection, I get "Could not connect to host or select database." If I proceed anyway, here is the full error that I get: SQLSTATE[42000] [1044] Access denied for user '35443427_xxdb_u33'@'%' to database '35443427_xxdb' Host Name: please check that it is correctDatabase Name: please check that it is correctUsername: please check that it is
  11. I ran into an import issue today resulting from the 40 char length on the "name" field in the Accounts table. I noticed other fields with similar lengths. May I suggest re-evaluating the field lengths in the database? In my case there were a bunch of account names that were long, often as a result of clients entering their full DBA name, like this: "Crazy Bob's Car Wash, Inc. DBA Crazy Old Bob" (44 char) So when I imported the accounts, then contacts, the contacts which relate to accounts with long names did not match up. This is just a small example of the consequences of field length
  12. I have a MySQL database with WordPress tables in it. I'd like to use that same database for X2. Will X2 install to it, or will it wipe out everything before it installs (Drop if Exists...)? Right now I'm happy for there to be two applications... the site and the CRM. Eventually I'd like to find a way to access/update the CRM from within a WordPress page, but at this point it isn't a big deal. I just want to share the same DB to keep all the "stuff" in one place. Thanks, Al
×
×
  • Create New...