Jump to content


X2Clifton

Member Since 15 Nov 2018
Offline Last Active Jul 02 2020 08:32 AM
-----

Posts I've Made

In Topic: Update to x2 version 8.0

23 March 2020 - 08:27 AM

Hi DonnaParrish,

 

I've tested and confirmed this problem, and will let you know when a fix is available!


In Topic: External Search through URL

16 March 2020 - 11:23 AM

Hi Success,

 

As of now it's not possible to use a link that redirects directly to the record within the application. However if they just need other details about the record, they can use the API. If they are a user and have their API key (if they don't only an admin user can give it to them by going to Users > *Select User* > Update User and copy their API Key), they can go to a link like this:

http://www.domain.com/index.php/api2/Contacts/by:phone=1234567890.json

This searches the contacts module for a record with the "phone" field value "1234567890" and returns a JSON string of the contact info. I'll make sure to note that as a suggestion for a feature release! Let me know if this helps you! 


In Topic: Zapier 422 Post Error

13 March 2020 - 08:38 AM

Sounds great!


In Topic: Date/Time Formula calculation

13 March 2020 - 08:37 AM

Hi gfl,

 

Just to make sure I'm understanding correctly, are you asking if there's a way within the app to calculate these time differences? Or are you wanting to know how to take their epoch times from the database and calculate the minutes between the two?


In Topic: Zapier 422 Post Error

11 March 2020 - 08:52 AM

Hi Success,

 

From our wiki page on our API (http://wiki.x2crm.co...T_API_Reference), this the explanation behind that error code:

Unprocessable entity. This always indicates a data validation error when attempting to set fields of and save an active record model. The client is expected to resolve these issues and resubmit the data with all of the fields formatted in such a way that it is acceptable.

 

It seems that one or more of the fields you have for the record you are trying to create has data that is not formatted as expected. I would take a look at any custom fields in the admin panel under X2Studio Customization Tools > Manage Fields and make sure that all of the fields for your record have data that conform to the format you specified, assuming you have custom fields for the active record model you are trying to create. If not custom, if you have MySQL access for the app, check the table for the datatypes expected for the fields of that model. Let me know if you have further issues resolving this error code.