Jump to content


Happy Web Stuff

Member Since 14 Jul 2018
Offline Last Active Jul 15 2018 06:21 AM
-----

Topics I've Started

500 Errors On New Installation

14 July 2018 - 09:07 PM

Hello, 

 

I have installed x2 for the first time. I am getting 500 errors when trying to login.

 

if I delete the cache files "/protected/runtime/cache" I can see the login screen

 

I try to login

 

500 error again

 

logs say:

2018/07/15 04:53:42 [error] [php] unserialize(): Unexpected end of serialized data (/home/MYUSER/public_html/MYFOLDER/framework/caching/CCache.php:108)
Stack trace:
#0 /home/MYUSER/public_html/MYFOLDER/framework/db/ar/CActiveRecord.php(2386): CMysqlSchema->getTable()
#1 /home/MYUSER/public_html/MYFOLDER/framework/db/ar/CActiveRecord.php(411): CActiveRecordMetaData->__construct()
#2 /home/MYUSER/public_html/MYFOLDER/framework/db/ar/CActiveRecord.php(661): Modules->getMetaData()
#3 /home/MYUSER/public_html/MYFOLDER/framework/db/ar/CActiveRecord.php(1523): Modules->getTableSchema()
#4 /home/MYUSER/public_html/MYFOLDER/protected/components/behaviors/ApplicationConfigBehavior.php(986): Modules->findByAttributes()
#5 /home/MYUSER/public_html/MYFOLDER/protected/components/behaviors/ApplicationConfigBehavior.php(323): ApplicationConfigBehavior->importDirectories()
#6 /home/MYUSER/public_html/MYFOLDER/framework/base/CComponent.php(561): ApplicationConfigBehavior->beginRequest()
#7 /home/MYUSER/public_html/MYFOLDER/framework/base/CApplication.php(212): X2WebApplication->raiseEvent()
#8 /home/MYUSER/public_html/MYFOLDER/framework/base/CApplication.php(183): X2WebApplication->onBeginRequest()
#9 /home/MYUSER/public_html/MYFOLDER/index.php(64): X2WebApplication->run()
REQUEST_URI=/index.php/site/needsTwoFactor
 
I searched high and low for an answer and can't find anything. I have changed permissions to 664, 755 and even 777 to test and I still get the 500 error.
 
Any help is appreciated.