Jump to content


Attila

Member Since 14 Jun 2017
Offline Last Active Today, 12:57 AM
-----

Posts I've Made

In Topic: How To create list of contacts that opened mass email

12 February 2019 - 03:55 AM

One would create a workflow - "Campagne Email opened"  there are various to do this and specify delays in responding   


In Topic: 500 Error after installation

08 February 2019 - 11:13 PM

from X2 ver 7.1  compatible with PHP 7.2+ and earlier 

 

http://community.x2c...ort-for-php-72/

 

Also note that there is a code issue that there is a hot fix coming  to resolve an issue with php7.2+ 

 

In the meantime you can edit the following according to X2Peter 

 

 

 

 

  • photo-thumb-11119.jpg?_r=1522885564
  • Administrators
  • admin.png
  • 73 posts

Posted 28 January 2019 - 07:47 PM

This appears to be caused by a null variable ($hiddenTags) within protected/components/TagCloud.php. We will provide a hotfix patch this week. You can also replace:


  1. if(count($hiddenTags)>0){
  2. $tagParams = AuxLib::bindArray ($hiddenTags);
  3. $params = array_merge ($params, $tagParams);
  4. $str1=" AND tag NOT IN (".implode (',', array_keys ($tagParams)).")";
  5. }else{
  6. $str1="";
  7. }

to:


  1. if(!is_null($hiddenTags) && count($hiddenTags)>0){
  2. $tagParams = AuxLib::bindArray ($hiddenTags);
  3. $params = array_merge ($params, $tagParams);
  4. $str1=" AND tag NOT IN (".implode (',', array_keys ($tagParams)).")";
  5. }else{
  6. $str1="";
  7. }

in protected/components/TagCloud.php

 

 
  •  

 


In Topic: emails received marked as sent by me in contacts

08 February 2019 - 11:09 PM

Would you take a screen-shot of what you see .... 


In Topic: Can't view email content after popup shows up

08 February 2019 - 11:06 PM

did you upgrade or fresh install, 

 

If it was an upgrade, you need to edit and re-verify all email addresses again:   User - Manage Apps - Manage Passwords for 3rd-party Apps.....      


In Topic: SORTED - Upgrade to ver 7.1 missing - SORTED

31 January 2019 - 03:01 AM

Yes I did ...  this was all published after I had posted posted this topic  also marked it "sorted"