Jump to content


Success

Member Since 14 Feb 2015
Offline Last Active Mar 29 2020 03:41 PM
-----

Posts I've Made

In Topic: Zapier 422 Post Error

16 March 2020 - 01:09 AM

@X2Clifton,

I'm making progress.  It seems some of the test data from Zapier was not good and I'm getting past the original issue.

is the Workflow Trigger supposed to work with Zapier?

I'm trying to get a workflow to trigger when a new contact is added from Zapier and it does not appear to work.


In Topic: Zapier 422 Post Error

13 March 2020 - 12:44 AM

Hi Success,

 

From our wiki page on our API (http://wiki.x2crm.co...T_API_Reference), this the explanation behind that error code:

Unprocessable entity. This always indicates a data validation error when attempting to set fields of and save an active record model. The client is expected to resolve these issues and resubmit the data with all of the fields formatted in such a way that it is acceptable.

 

It seems that one or more of the fields you have for the record you are trying to create has data that is not formatted as expected. I would take a look at any custom fields in the admin panel under X2Studio Customization Tools > Manage Fields and make sure that all of the fields for your record have data that conform to the format you specified, assuming you have custom fields for the active record model you are trying to create. If not custom, if you have MySQL access for the app, check the table for the datatypes expected for the fields of that model. Let me know if you have further issues resolving this error code.

 

 

Ok, thanks for the reply.  I'll take a look.

I had already started the process of removing fields to narrow down the problem but this makes sense.

Thanks for your time and I'll report back if further issues.


In Topic: Zapier App only has few fields, how to populate more

08 August 2019 - 04:08 PM

X2Peter Thanks for your suggestion.

I created a new Role for Zapier specifically and have a API User setup where I selected the fields to edit.

I then edited the Role list to give it rights to create contacts.

However, still no results in Zapier.

Do you know what I might be doing wrong?

Thanks!


In Topic: NO ZAPIER SUPPORT IS KILLING X2 CRM

01 August 2019 - 04:34 PM

Hey guys, I hit another problem with creating a contact and only showing 4 fields to be populated, howerver upon submitting test data you see what appear to be all the other contact fields but null.

I stared a new thread, but wanted to update you guys here as well...
 

Any help would be appreciated...

http://community.x2c...-populate-more/


In Topic: NO ZAPIER SUPPORT IS KILLING X2 CRM

18 June 2019 - 01:29 PM

Peter,

I was trying to do some new zapier integration and when tried to setup the Zapier API I get the following error!

Any ideas where to start?

zSVYNH.jpg