Jump to content
X2Community Forums

X2CRM version 8.5 - Google Email Account with Oauth2 - Error 500

Recommended Posts


I'm not able to set up Gmail.
I'm not sure if this is a bug in the 8.5 version of X2CRM or is related to my server configuration or other settings.
Any help and suggestion will be very much appreciated.

I installed X2CRM 8.5 Open Source edition on two hosting accounts, for testing purposes.
One relies on CPanel, with a dedicated IP address and another is a cheap Hostinger 'h-panel' hosting plan.

On both of them, I am not able to set up Gmail.
I tried both the 'Google Email Account with Oauth2' and 'Google Email Account', at 'Manage Apps' in X2CRM.
Verifying Credentials always returns: 'Failed to authenticate. Please check your credentials', with right credentials entered.
I triple-checked the credentials and tried them in the browser, to make sure they work.
Also, I tried switching on and off all the available options: disabling SSL Validation, changing the IMAP security to TLS, SSL and none - with the same result.

Clicking on 'Save' produces the following 500 error.
(I replaced the domain specifics with 'TLD').

Error Code: 500
Error Message: Trying to get property 'auth' of non-object
Stack Trace: [click to toggle display]
PHP notice in /home/TLD/protected/controllers/ProfileController.php(816)
#0 /home/TLD/protected/controllers/ProfileController.php(682): ProfileController->setGoogleOauth2()
#1 unknown(0): ProfileController->actionCreateUpdateCredentials()
#2 /home/TLD/framework/web/actions/CAction.php(115): ReflectionMethod->invokeArgs()
#3 /home/TLD/framework/web/actions/CInlineAction.php(47): CInlineAction->runWithParamsInternal()
#4 /home/TLD/framework/web/CController.php(308): CInlineAction->runWithParams()
#5 /home/TLD/framework/web/filters/CFilterChain.php(134): ProfileController->runAction()
#6 /home/TLD/protected/controllers/x2base.php(587): CFilterChain->run()
#7 /home/TLD/framework/web/filters/CInlineFilter.php(58): ProfileController->filterSetPortlets()
#8 /home/TLD/framework/web/filters/CFilterChain.php(131): CInlineFilter->filter()
#9 /home/TLD/framework/web/filters/CFilter.php(40): CFilterChain->run()
#10 /home/TLD/framework/web/CController.php(1148): CAccessControlFilter->filter()
#11 /home/TLD/framework/web/filters/CInlineFilter.php(58): ProfileController->filterAccessControl()
#12 /home/TLD/framework/web/filters/CFilterChain.php(131): CInlineFilter->filter()
#13 /home/TLD/protected/controllers/x2base.php(587): CFilterChain->run()
#14 /home/TLD/framework/web/filters/CInlineFilter.php(58): ProfileController->filterSetPortlets()
#15 /home/TLD/framework/web/filters/CFilterChain.php(131): CInlineFilter->filter()
#16 /home/TLD/framework/web/filters/CFilter.php(40): CFilterChain->run()
#17 /home/TLD/framework/web/filters/CFilterChain.php(131): FileUploadsFilter->filter()
#18 /home/TLD/framework/web/filters/CFilter.php(40): CFilterChain->run()
#19 /home/TLD/framework/web/filters/CFilterChain.php(131): X2AjaxHandlerFilter->filter()
#20 /home/TLD/framework/web/CController.php(291): CFilterChain->run()
#21 /home/TLD/framework/web/CController.php(265): ProfileController->runActionWithFilters()
#22 /home/TLD/framework/web/CWebApplication.php(282): ProfileController->run()
#23 /home/TLD/protected/components/X2WebApplication.php(67): X2WebApplication->runController()
#24 /home/TLD/framework/base/CApplication.php(185): X2WebApplication->processRequest()
#25 /home/TLD/index.php(69): X2WebApplication->run()
X2Engine Version: 8.5
PHP Version: 7.4.32

Any ideas on what I could do to fix this ?




Link to post
Share on other sites

I enabled the 'oauth' PHP  extension on the above server, running on PHP 7.4 and X2Engine 8.5..
This didn't make any difference, as far as setting up a Gmail account in X2CRM.
I still got the same Error 500 and the same 'Failed to authenticate .. ' message.

However, I was able to set up a personal Outlook.com email account, by using the 'Office 365 Email Account' configuration, in 'Manage Apps'.
Outlook.com first treated the attempted login as suspicious and blocked the account, but after I logged in and confirmed that it was me, the authentication went through, in X2CRM.
At least something is working ... 🙂

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...