Jump to content


Photo

How to set php version for x2crm that is different to the cpanel hosting version?


  • Please log in to reply
2 replies to this topic

#1 gfl

gfl

    Advanced Member

  • Members
  • PipPipPip
  • 43 posts

Posted 06 May 2020 - 12:02 AM

I'm hosting an x2crm on namecheap shared server hosting.

 

Unless the cpanel php is set to version 5.6 or thereabouts x2crm wont run. X2crm wont run when cpanel php is set to latest version.

 

I want to set PHP to the latest for hosting other apps, including wordpress.

 

I've tried recommended app php versioning, by adding code to .htaccess and including a php version 5.6 php.ini file, etc:

<FilesMatch ".(?:html|php)$">
SetHandler application/x-lsphp56
</FilesMatch>
lsapi_phpini /home/eoptz/3.eoptz.com//php.ini
 

 

Unless the cpanel php is set to version 5.6 x2crm wont run.

 

The current error message is Fatal error: Interface 'IBehavior' not found in /home/eoptz/3.eoptz.com/framework/base/CBehavior.php on line 21.



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 369 posts
  • LocationGermany

Posted 07 May 2020 - 12:15 AM

<FilesMatch "\.(php4|php5|php7|php3|php2|php|phtml)$">
SetHandler application/x-lsphp56
</FilesMatch>



#3 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 369 posts
  • LocationGermany

Posted 28 May 2020 - 12:41 AM

Hi gfl,

 

Did it  :) ?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users