Jump to content
X2Community Forums

Can't create a new module in Version 8


Recommended Posts

Hi guys,

 

I tried creating a new module in a brand new install. Has anyone gotten this error:

 

Error Code: 500
Error Message: CDbCommand failed to execute the SQL statement: SQLSTATE[23000]: Integrity constraint violation: 1217 Cannot delete or update a parent row: a foreign key constraint fails
Stack Trace: [click to toggle display]
X2Engine Version: 8.0
PHP Version: 7.0.33-0ubuntu0.16.04.12

 

I tried various things during the creation process but end up with this 1217 error

 

Any advise?

 

Thanks

Link to post
Share on other sites

SOLVED!

 

Hi Jack, I found the problem. I am trying to create a module called Events. Not realizing X2 has its own Events module already, creating the bug as its trying to remove the existing one. Thats also why it happened in my tests in other X2 instances I have. I tested using Events.

 

Sorry guys, my bad. I should have looked at the existing modules in the DB first.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...