Jump to content
X2Community Forums

Recommended Posts

Hey guys and gals,

I'm using 7.1 open source, self-hosted.

When I go to /x2crm/index.php/admin/updater

its runs for awhile and then...

Update X2Engine to 8.0 from 7.1

Errors encountered.

Could not complete operation because the request to the server failed or timed out. (error undefined )




Obtain and check data
Review and confirm changes
Download package
Extract package
Verify package contents
Apply changes
  • Like 1
Link to post
Share on other sites
  • 3 months later...

In your 8.0 release notes, you state: Note for sales quotes after updating to 8.0
With the new quote creator changes, quotes appear differently. Quotes already stored in the database will still have comments for line items, but will not be seen on the view/update/print pages. In order to make sure comments show properly, you will need to run the FixOldQuotesCommand command. To do this, navigate to your application directory and then to the protected/ directory. Then run ./yiic fixoldquotes to move all line items' comments to it's own line item.


What about old adjustments? We ran fixoldquotes, and it fixed comments but it did not seem to fix adjustments.

  • Like 1
Link to post
Share on other sites


Upgrade gives a following error:


Exception: "CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away" in /x2system/framework/db/CDbCommand.php L543


I've tried to increase max_allowed_packet to 1GB and timeout settings to maximum possible. Error still persists. What else can be done here?


Thanks a lot in advance!

Link to post
Share on other sites

Seems to be a timeout problem.


Try to "SET session wait_timeout=14400" and/or "SET session interactive_timeout=14400or increasing to servers´ maximum (at least for import). 14400 = 4 hrs, should be enough ;-)



  • Like 1
Link to post
Share on other sites
  • 4 weeks later...

Hi all. 


Having this same error across a recent install today. 


Can someone point me in the right direction of where to place these commands to set session. 


SET session wait_timeout=14400


SET session interactive_timeout=14400






  • Like 1
Link to post
Share on other sites
  • 2 months later...

Where can I direct download X2 8.0?


SET session wait_timeout=14400


SET session interactive_timeout=14400



These are MySQL timeout settings. Unfortunately, in a shared hosting environment we are not able to change them off of the default settings.


Walben Whitebrew
WebHostingPad Support

Link to post
Share on other sites
  • 5 months later...

Those changes resulted in the same error message. However, when trying to update from 7.1 to 8 using cli i get the following output:

The updater is up-to-date and safe to use.
Some requirements for running X2Engine at the latest version are not met on this server:
        Could not reach the updates server from this web server. This is likely because the server is behind a firewall that is preventing outbound HTTP/HTTPS requests. Software updates will have to be performed using the "offline" method. This may be a temporary problem.
        PHP is running with user ID=0, but this directory is owned by the system user with ID=48.
        The path defined in session.save_path () is not writable.
Note that the following files, of which there are local custom derivatives, will be changed:
I have tried with firewall off. Is this a requirements or permission issue?
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...