Jump to content


Photo

Update to x2 version 8.0

update newest version 8.0

  • Please log in to reply
11 replies to this topic

#1 DeantheTaxGuy

DeantheTaxGuy

    Newbie

  • Members
  • Pip
  • 1 posts
  • LocationMission Viejo, CA USA

Posted 11 December 2019 - 10:49 AM

Hey guys and gals,

I'm using 7.1 open source, self-hosted.

When I go to /x2crm/index.php/admin/updater

its runs for awhile and then...

Update X2Engine to 8.0 from 7.1

Errors encountered.

Could not complete operation because the request to the server failed or timed out. (error undefined )

 

 

 

Obtain and check data
Review and confirm changes
Download package
Extract package
Verify package contents
Apply changes
Reload


#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 379 posts
  • LocationGermany

Posted 11 December 2019 - 10:45 PM

Hi Dean,

 

our update was hasselfree.

 

Did you check the PHP timeout-settings or tried to increase them?

 

Regards!



#3 DonnaParrish

DonnaParrish

    Member

  • Members
  • PipPip
  • 21 posts

Posted 18 March 2020 - 10:42 AM

In your 8.0 release notes, you state: Note for sales quotes after updating to 8.0
With the new quote creator changes, quotes appear differently. Quotes already stored in the database will still have comments for line items, but will not be seen on the view/update/print pages. In order to make sure comments show properly, you will need to run the FixOldQuotesCommand command. To do this, navigate to your application directory and then to the protected/ directory. Then run ./yiic fixoldquotes to move all line items' comments to it's own line item.

 

What about old adjustments? We ran fixoldquotes, and it fixed comments but it did not seem to fix adjustments.



#4 X2Clifton

X2Clifton

    Advanced Member

  • Moderators
  • 49 posts

Posted 23 March 2020 - 08:27 AM

Hi DonnaParrish,

 

I've tested and confirmed this problem, and will let you know when a fix is available!



#5 Walter

Walter

    Member

  • Members
  • PipPip
  • 27 posts
  • LocationMiddle East

Posted 26 March 2020 - 01:59 PM

Hi,

Upgrade gives a following error:

 

Exception: "CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away" in /x2system/framework/db/CDbCommand.php L543

 

I've tried to increase max_allowed_packet to 1GB and timeout settings to maximum possible. Error still persists. What else can be done here?

 

Thanks a lot in advance!



#6 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 379 posts
  • LocationGermany

Posted 01 April 2020 - 11:16 PM

Seems to be a timeout problem.

 

Try to "SET session wait_timeout=14400" and/or "SET session interactive_timeout=14400or increasing to serversĀ“ maximum (at least for import). 14400 = 4 hrs, should be enough ;-)

 

Regards!



#7 Walter

Walter

    Member

  • Members
  • PipPip
  • 27 posts
  • LocationMiddle East

Posted 07 April 2020 - 05:18 PM

Thanks a lot alt_f4 - upgraded successfully 



#8 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 379 posts
  • LocationGermany

Posted 08 April 2020 - 04:52 AM

Welcome :-) and stay healty



#9 ChrisM

ChrisM

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 04 May 2020 - 11:20 AM

Hi all. 

 

Having this same error across a recent install today. 

 

Can someone point me in the right direction of where to place these commands to set session. 

 

SET session wait_timeout=14400

 

SET session interactive_timeout=14400

 

Thanks

 

 

 



#10 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 379 posts
  • LocationGermany

Posted 07 May 2020 - 12:17 AM

your PHP settings (depends on your hoster where to set it)



#11 steals

steals

    Advanced Member

  • Members
  • PipPipPip
  • 31 posts

Posted 06 August 2020 - 01:37 PM

Where can I direct download X2 8.0?

 

SET session wait_timeout=14400

 

SET session interactive_timeout=14400

 

Hello,
 

These are MySQL timeout settings. Unfortunately, in a shared hosting environment we are not able to change them off of the default settings.

Regards,

Walben Whitebrew
WebHostingPad Support



#12 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 379 posts
  • LocationGermany

Posted 10 August 2020 - 01:29 AM

Try to define a php.ini and put it to your root; may your provider support the custom settings.

 

The direct download of X2 v8 seems not to be possible (waiting since months...), but the update-download is availabe through the X2 admin / settings page https://your_path_to_x2/index.php/admin/updater







Also tagged with one or more of these keywords: update, newest version, 8.0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users