Jump to content


Photo

Contact Web activity trigger and unsubscribe form

Webform

  • Please log in to reply
3 replies to this topic

#1 ChrisM

ChrisM

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 07 December 2019 - 02:51 PM

Hey Guys,

 

I think I am missing something. 

 

I have installed 2 web lead capture forms on my site url removed in two languages. I have also included a confirmation email process which uses the trackingKey field in a url link to prove someone has visited a confirmation page on my site. If you want to check the process for the user, I have only setup the confirmation email for the English newsletter form in the footer of most pages on the website, others don't send emails yet.

 

Two issues arise from this. 

 

1, In the Contact Web Activity trigger. I cant seem to compare the url removed  that's in the url that I have asked the user to click on in the email, to the {trackingKey}. .  The url removed } does not populate in the compare field, so the trigger logs shows the action fails on click. At the moment I only have success with just checking that the user has landed on the hidden newsletter confirmation page without the trackingKey appended..Is there a way for the Contact Web Activity trigger to compare that a user has clicked the url appended with the trackingKey, or a work around for this process? 

 

2, I have also placed the unsubscribe code on my website, but I have only ever ( 3 months of use) seen the text "You have been successfully unsubscribed" both on my site, and on the Web Form Creator page, even when I have tested a number of browsers to subscribe and ask for information etc. The point being I should be subscribed, so I should see different information from the code.  Users can get to the unsubscribe page from the site map in the footer.  Even subscribing to the news letter form in the CRM does not make any difference, (I am in Europe, so I need additional check boxes for privacy etc when someone wishes to subscribe). Is there a field I need to check in the CRM...somewhere? What is going wrong?

 

I feel I am asking questions that others have not had issues with, as I cannot see anything on the forums. 

 

Any suggestions for the work flow engine or code somewhere? 

 

 

Thanks all. 

 

Chris

 

 

 

PS. Well done team, 8.0 looks great :)

 

 

 

 

 

 

.



#2 jack

jack

    Admin

  • Administrators
  • 44 posts

Posted 10 December 2019 - 11:41 AM

Hi Chris, 

For number one if you want to be able to use the tracking key for other purposes you have to make an entry for it in the (x2_fields) table. For number 2 if you are trying to set up an unsubscribe page you can do so from under email settings in the admin panel. If you are asking about why it does not look different for different users our current software does not check if you are already unsubscribed. It shows the same page no matter what email is passed in. For setting opt in you should add your own custom field for opt in and build a list off of that.

Hope this info helps.

-Jack



#3 ChrisM

ChrisM

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 10 December 2019 - 02:44 PM

Thanks Jack, 

 

Just to confirm, here is the log from the trigger record

 

December 2, 2019, 10:47:58 AM

Trigger: Contact Web Activity (Success: View record:Url removed
Execute Branch:  
I have a preference for the {trackingKey} to be populated with the right number. I have placed {trackingKey} in the "Contact Web Activity
Triggered when a contact visits a webpage" - URL box in URL removed
so the trigger only fires when the contact clicks on the link the contains the trackingKey. 

 

looking through myPHPadmin, I have 4 fields in trackingKey in x2_fields from AnonContact, Accounts, Contacts, and X2Leads. Whats else do I need to add, where do I add it and how?

 

On two, my website and the Unsubscription form preview atUrl removed always shows :"You have been successfully unsubscribed.", even when I know I am actually subscribed. I am guessing I should actually see a box to submit an email address in..?.



#4 jack

jack

    Admin

  • Administrators
  • 44 posts

Posted 17 December 2019 - 02:30 PM

Chris,

The form preview is showing our default of "You have been successfully unsubscribed." until you set up you own in the email settings under the admin options.

For the execute branch check, I would recommend just adding a constant value in the URL you can check for instead of the tracking key.

-Jack







Also tagged with one or more of these keywords: Webform

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users