Jump to content


Photo

Can't install on a VPS, at all.


  • Please log in to reply
3 replies to this topic

#1 s3_gunzel

s3_gunzel

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 22 October 2019 - 02:56 AM

So I've been trying to install following this guide: https://websiteforst...hp-7-2-support/ repeatedly for about a week. I cannot install X2CRM as the installer never loads. It consistently times out my sockets for PHP. I have no way around this. I have also tried Apache. Also does not work. Also times out. I've tried PHP 7.2, PHP 7.0, and PHP 5.6, all time out as well. 

 

Is there a proper installation guide that I can follow? The one on this website does not assist me either. 



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 377 posts
  • LocationGermany

Posted 22 October 2019 - 08:00 AM

Do you have some more details? Error log?

 

Should be a simple job: upload, have an installed MySQL and PHP (7.3 would be a fit) and go to the installer. If you want, send me a PM and I´d be able to assist.

 

As a pre-check, upload http://x2planet.com/...equirements.php to your webserver and see :-)



#3 villagetech

villagetech

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 05 February 2020 - 05:47 AM

I'm having the same issue.

 

I've setup a VM with Ubuntu 18.04 and followed a guide here (https://websiteforst...hp-7-2-support/)

 

I've also tried setting up with Virtualmin and Apache, but I get the same thing. The install.php just times out, even though requirements.php says everything is good.

 

nginx error.log....

[error] 18397#18397: *1 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 10.0.10.35, server: 10.0.10.63, request: "GET /install.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.2-fpm.sock", host: "10.0.10$...

 

It's a shame because we're really keen to try this out, but I just can't make it work.



#4 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 377 posts
  • LocationGermany

Posted 05 February 2020 - 11:21 PM

Try to upload http://x2planet.com/...equirements.php to your server and see what the log (PHP!!) says...

 

X2-Engine-System-Requirements-Check.png






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users