Jump to content


Photo

Class 'X2LinkableBehavior' not found


  • Please log in to reply
4 replies to this topic

#1 lbernhardt

lbernhardt

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 October 2019 - 11:26 AM

hello members
I just updated the crm to version 7.1 but after the installation I have the following problem.
 
PHP Fatal error:  Class 'X2LinkableBehavior' not found in /opt/bitnami/apps/x2crm/htdocs/framework/YiiBase.php on line 227, referer: http://192.168.5.204....php/site/login
 
how can I solve it? 
 
thanks for your help


#2 X2Clifton

X2Clifton

    Member

  • Moderators
  • 12 posts

Posted 03 October 2019 - 08:32 AM

Hi lbernhardt,

 

Could you upload a screenshot of the stack trace when this error is shown?



#3 lbernhardt

lbernhardt

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 03 October 2019 - 09:39 AM

hello X2Clifton
After login the page goes blank and shows nothing.
that error shows it in the error_log of apache2 and there is no previous stack trace, only that line.
It was the only thing I could find and it is not very descriptive.
 
Thank you


#4 X2Clifton

X2Clifton

    Member

  • Moderators
  • 12 posts

Posted 03 October 2019 - 01:11 PM

I believe this forum thread might help point you in the right direction. This also deals with issues after upgrading to a newer version and encountering a blank screen. Let me know if this helps!

 

http://community.x2c...-update-issues/



#5 lbernhardt

lbernhardt

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 October 2019 - 05:14 AM

thanks X2Clifton,
It has been very useful, I had not found this thread before you suggested it to me.
 
regards





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users