Jump to content


Photo

500 Error after installation


  • Please log in to reply
4 replies to this topic

#1 broms

broms

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 11 December 2018 - 12:28 PM

I installed and everything seemed to go fine, I got the Installation Complete screen, but when I click to login (or if I manually load index.php), i get a 500 error.

 

apache log has:

PHP Notice:  unserialize(): Unexpected end of serialized data in /srv/http/X2Engine/X2CRM-master/x2engine/framework/caching/CCache.php on line 108, referer: http://myhost/X2Engine/X2CRM-master/
PHP Notice:  unserialize(): Error at offset 0 of 1 bytes in /srv/http/X2Engine/X2CRM-master/x2engine/framework/caching/CCache.php on line 108, referer: http://myhost/X2Engine/X2CRM-master/
PHP Fatal error:  Declaration of X2WebUser::checkAccess($operation, $params = Array) must be compatible with CWebUser::checkAccess($operation, $params = Array, $allowCaching = true) in /srv/http/X2Engine/X2CRM-master/x2engine/protected/components/X2WebUser.php on line 38    , referer: http://myhost/X2Engine/X2CRM-master/

Using php version 7.3.0-1, mariadb 10.1.37-1 (mysql=5.6), apache 2.4.37-1 on arch linux 4.19-2

 

any idea what is wrong and how to fix?



#2 rordallas

rordallas

    Member

  • Members
  • PipPip
  • 14 posts

Posted 14 December 2018 - 02:45 AM

I don't think x2crm is compatible with any php version > 7.0 (yet).



#3 X2Clifton

X2Clifton

    Newbie

  • Moderators
  • 5 posts

Posted 21 December 2018 - 11:18 AM

Hi broms,

 

We are currently working on migrating to PHP version 7.2, it should be out within the coming month.



#4 mirecart

mirecart

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationManchester

Posted 05 February 2019 - 07:09 AM

Hi broms,

 

We are currently working on migrating to PHP version 7.2, it should be out within the coming month.

 

Hi,

 

Is this now available for PHP Version 7.0 or beyond, and if so is that for X2 6.9 or just the 7.0 edition. ??

 

Warm regards,

 

Michael 



#5 Attila

Attila

    Advanced Member

  • Members
  • PipPipPip
  • 146 posts
  • LocationJohannesburg, South Africa

Posted 08 February 2019 - 11:13 PM

from X2 ver 7.1  compatible with PHP 7.2+ and earlier 

 

http://community.x2c...ort-for-php-72/

 

Also note that there is a code issue that there is a hot fix coming  to resolve an issue with php7.2+ 

 

In the meantime you can edit the following according to X2Peter 

 

 

 

 

  • photo-thumb-11119.jpg?_r=1522885564
  • Administrators
  • admin.png
  • 73 posts

Posted 28 January 2019 - 07:47 PM

This appears to be caused by a null variable ($hiddenTags) within protected/components/TagCloud.php. We will provide a hotfix patch this week. You can also replace:


  1. if(count($hiddenTags)>0){
  2. $tagParams = AuxLib::bindArray ($hiddenTags);
  3. $params = array_merge ($params, $tagParams);
  4. $str1=" AND tag NOT IN (".implode (',', array_keys ($tagParams)).")";
  5. }else{
  6. $str1="";
  7. }

to:


  1. if(!is_null($hiddenTags) && count($hiddenTags)>0){
  2. $tagParams = AuxLib::bindArray ($hiddenTags);
  3. $params = array_merge ($params, $tagParams);
  4. $str1=" AND tag NOT IN (".implode (',', array_keys ($tagParams)).")";
  5. }else{
  6. $str1="";
  7. }

in protected/components/TagCloud.php

 

 
  •  

 


Never allow waiting to become a habit. Live your dreams & take risks. Life is happening NOW !





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users