Jump to content
X2Community Forums

6.9.3 -> 7: cannot upgrade with error attached


Recommended Posts

I encountered the error as described in the error below when I press the upgrade button trying to upgrade to version 7.

 

OS: Ubuntu 18.04

 

Error 500

It looks like the application ran into an unexpected error. 

We apologize for the inconvenience and would like to do our best to fix this issue. If you would like to make a post on our forums we can actively interact with you in getting this resolved. If not, simply sending the error report helps us immensely and will only improve the quality of the software. Thanks!
Send Error Report
Here's a quick list of what will be included in the report:

Error Code: 500
Error Message: Cannot verify package contents. Checksum file is missing.
Stack Trace: [click to toggle display]
X2Engine Version: 6.9.3
PHP Version: 7.0.32-2+ubuntu18.04.1+deb.sury.org+1

Email Address (optional)

Include phpinfo()? (optional, but recommended) 

Please Note: Any information in the $_GET or $_POST arrays included with the request will also be sent with the report.
Link to post
Share on other sites

Yes, see below:

 

$ ls -l

total 128

drwxr-xr-x 13 www-data www-data  4096 Jan 16  2018 assets

drwxr-xr-x  6 www-data www-data  4096 Dec 14  2014 compass

-rw-r--r--  1 www-data www-data   504 May 24  2016 constants-custom.example.php

-rw-r--r--  1 www-data www-data  1776 Jan  2  2018 constants.php

drwxr-xr-x  3 www-data www-data  4096 Feb  4  2015 css

drwxr-xr-x  3 www-data www-data  4096 Jan 25  2014 custom

-rw-r--r--  1 www-data www-data  2782 Jan  2  2018 email.php

drwxr-xr-x 19 www-data www-data  4096 Jan 25  2014 framework

drwxr-xr-x  3 www-data www-data  4096 May 24  2016 images

-rw-r--r--  1 www-data www-data  3387 Jan  2  2018 index.php

-rw-r--r--  1 www-data www-data  2518 Jan  2  2018 index-test.php

drwxr-xr-x 30 www-data www-data  4096 Jan  2  2018 js

-rw-r--r--  1 www-data www-data 32336 May 24  2016 LICENSE.txt

drwxr-xr-x 17 www-data www-data  4096 May 24  2016 protected

-rw-r--r--  1 www-data www-data  1043 May 24  2016 resolve_self.php

drwxr-xr-x  4 www-data www-data  4096 Jan  2  2018 themes

drwxr-xr-x  2 www-data www-data  4096 Oct 16 17:46 update

-rw-r--r--  1 www-data www-data    47 May 24  2016 updater.php

drwxr-xr-x  4 www-data www-data  4096 Nov 29  2016 uploads

-rw-r--r--  1 www-data www-data   522 Feb  7  2014 webLeadConfig.php

-rw-r--r--  1 www-data www-data  4248 Jan  2  2018 webListener.php

 

-rw-r--r--  1 www-data www-data 10331 Jan  2  2018 webTracker.php

Link to post
Share on other sites

Following the manual update and encountered below message, pls advise how to install these packages under Ubuntu 18.04:

Some requirements for running X2Engine at the latest version are not met on this server:

Minor
  • The "openssl" and "mcrypt" libraries are not available. If any application credentials (i.e. email account passwords) are entered into X2Engine, they will be stored in the database in plain text (without any encryption whatsoever). Thus, if the database is ever compromised, those passwords will be readable by unauthorized parties.
Major
  • cURL: required but missing. This will result in the following issues:
    • Time zone widget will not work
    • Google integration will not work
    • Built-in error reporter will not work
    • API web hooks (and thus, Zapier integration) will not work
    • Twitter integration will not work
    Furthermore, please note: without this extension, the requirements check script could not check the outbound internet connection of this server.
Link to post
Share on other sites

Finally get it updated to version 7.0 by installing these software packages:
 

(1) Install php-cli (command line interpreter) [Note: this is used to run php from the command line]

$ sudo apt-get install php7-cli 
You can checkPHP
version:
$
php
--version

 

 (2) Install ssh2:

$ sudo apt-get install libssh2-1 php-ssh2 

 

 (3) Install imap extension:

$ sudo apt-get install php7.0-imap

 

(4) Install mcrypt

$ sudo apt-get install php7.0-mcrypt

 

 (5) Install cURL + php-curl:

$ sudo apt-get install curl
$ sudo apt-get install php-curl

 

Restart Apache2 to make changes effective:

$ sudo systemctl restart apache2

Problem Solved!

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...