Jump to content


Photo

Error with translations - no findings in searchgrid

translate translation search finding foreign version 7 grid searchgrid

  • Please log in to reply
11 replies to this topic

#1 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 16 October 2018 - 04:40 AM

The translation files (de) used by us in version 6.9.3 are unusable with version 7. It seems, that this bug is also present with any other translation.

 

In the searchgrids (accounts, companies) is a search not longer possible (returns no findings). When switching to standard (using no translation file at all), everything seems to be fine.

 

 

May you can advise, what was changed. Even better: a quick solution. It´s a big problem for some of our users.

 

Regards!

 

 

 

Video (first you´ll see the finding of "11111" without any translation (english), next switching to translation (german) with no findings for same phrase).



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 16 October 2018 - 05:40 AM

Seems to be ONLY the case, if a dropdown-field is present in the grid ( -> was fixed with 6.9.3, now back again in combination with translations), see here



#3 X2Peter

X2Peter

    Advanced Member

  • Administrators
  • 81 posts

Posted 17 October 2018 - 03:27 PM

Hello alt_f4,

 

Thank your for the feedback. We are currently investigating this bug. I will update this thread with information as it comes in.



#4 X2Peter

X2Peter

    Advanced Member

  • Administrators
  • 81 posts

Posted 18 October 2018 - 02:33 PM

Hello alt_f4,

 

The dev team is currently investigating this issue, in particular with translations, and should have a bug fix ready by next point release. Thank you for the helpful video and examples!



#5 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 18 October 2018 - 10:36 PM

Always welcome!



#6 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 22 October 2018 - 11:12 AM

...hmm with going back to native language also every contact form was set back to english. That's too bad.

Any news on this case?

KR, alt_f4

#7 X2Peter

X2Peter

    Advanced Member

  • Administrators
  • 81 posts

Posted 23 October 2018 - 09:48 AM

Hello alt_f4,

 

We have the fix, it will be in the next release and I will post the solution here shortly as well.



#8 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 23 October 2018 - 09:44 PM

Hi Peter

 

That´s very helpfull, thanks!



#9 Attila

Attila

    Advanced Member

  • Members
  • PipPipPip
  • 146 posts
  • LocationJohannesburg, South Africa

Posted 24 October 2018 - 04:45 AM

Just a "wild and wooly" thought Peter....  maybe a roll back feature will be helpful in future releases.     


Never allow waiting to become a habit. Live your dreams & take risks. Life is happening NOW !


#10 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 24 October 2018 - 09:48 PM

+1 for a " roll back feature"



#11 X2Peter

X2Peter

    Advanced Member

  • Administrators
  • 81 posts

Posted 26 October 2018 - 02:09 PM

I believe this bug existed in 6.9.3 as well (tested on a 6.9.3 version of the app) however here is the fix:

 

protected/components/X2GridView/X2DataColumn.php:

return $model === "- ".Yii::t('app', 'Select')." -" ? '' : $model;

Let me know if you still have filtering issues after this fix.



#12 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 28 October 2018 - 04:09 AM

Hi Peter,

 

thanks for your fix, everything works like new :-)







Also tagged with one or more of these keywords: translate, translation, search, finding, foreign, version 7, grid, searchgrid

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users