Jump to content


Photo

No "do not email" option.

blacklist do not email bug error opt out mass email contact contacts email

  • Please log in to reply
3 replies to this topic

#1 PAM

PAM

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 24 September 2018 - 01:42 AM

I have been unable to figure out how to mark a contact as "do not email".
After some digging, I've realised there should be a simple check box present on the contact's page, but I don't have that.
Can anyone explain to me how I fix this, or if there is another way to blacklist a contact from being included in a mass email?

Thanks.



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 24 September 2018 - 04:19 AM

Hmmm, should be a standard field. It´s auto-set, if a contact opts-out. Or you can set it manually.

 

 

Try to check, if the field is present in .../index.php/admin/manageFields (admin-> X2Studio Module Customization Tools -> Manage Fields)

 

go to contacts, check for "do not email" should be a checkbox-field.

 

Additionally you should check if it´s visible in the form editor .../index.php/admin/editor?model=Contacts --> model = contacts

 

Regards!



#3 PAM

PAM

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 25 September 2018 - 08:01 AM

Hi alt_f4,

I managed to fix it in form editor. 
 

For anyone who's looking for a solution to the same problem,

  • I went to Admin > X2Studio Customisation Tools > Form Editor
  • Where it says "Model", I selected "Contacts" in the drop-down menu
  • In the "Version" drop-down, I selected "Form (Default)" - this is what you see when editing a contact
  • In the Field List to the right of the screen, I dragged the "Do Not Email" box onto the form on the left, then clicked save
  • I then went back to the "Version" drop-down list, at the top of the page, and selected "View (Default)". This is what you see when just viewing a contact, rather than editing it
  • I then followed the same steps as before and saved
  • Now you should have the "Do Not Email" checkbox available when either editing or viewing a contact
  • To tick it, you simply click the "edit" icon next to the box, tick or untick it, and save
  • (FIY - A green tick means do not email and a red x means do email)

I hope this is helpful, as I have been frustrated, trying to figure this out for weeks.

Thanks so much for your help, alt_f4!



#4 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 342 posts
  • LocationGermany

Posted 27 September 2018 - 06:39 AM

Always welcome & thanks for your hints :-)


  • Pmc likes this





Also tagged with one or more of these keywords: blacklist, do not email, bug, error, opt out, mass email, contact, contacts, email

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users