Jump to content
X2Community Forums

Error 500: CDbCommand failed to execute the SQL statement: SQLSTATE[22007]: Invalid datetime format: 1292 Truncated incorrect DOUBLE value: "


Recommended Posts

I did a fresh install last night (for testing purposes). It works fine for a few hours. Make a few test social posts, change the theme to black, upload a logo, walk away. Checked again today and now getting this error on login (nothing has changed with the install, and I have reproduced this problem 3x, each time happening on a fresh install, community version 6.9)

Error Code: 500
Error Message: CDbCommand failed to execute the SQL statement: SQLSTATE[22007]: Invalid datetime format: 1292 Truncated incorrect DOUBLE value: ''
Stack Trace:  [click to toggle display]
CDbException in /var/www/x2engine/framework/db/CDbCommand.php(358)
#0 /var/www/x2engine/protected/components/behaviors/CommonSiteControllerBehavior.php(79): CDbCommand->execute()
#1 /var/www/x2engine/framework/base/CComponent.php(261): CommonSiteControllerBehavior->login(Object(LoginForm))
#2 /var/www/x2engine/protected/controllers/SiteController.php(1517): CComponent->__call('login', Array)
#3 /var/www/x2engine/framework/web/actions/CInlineAction.php(49): SiteController->actionLogin()
#4 /var/www/x2engine/framework/web/CController.php(308): CInlineAction->runWithParams(Array)
#5 /var/www/x2engine/framework/web/filters/CFilterChain.php(133): CController->runAction(Object(CInlineAction))
#6 /var/www/x2engine/framework/web/filters/CFilter.php(40): CFilterChain->run()
#7 /var/www/x2engine/framework/web/CController.php(1145): CFilter->filter(Object(CFilterChain))
#8 /var/www/x2engine/framework/web/filters/CInlineFilter.php(58): CController->filterAccessControl(Object(CFilterChain))
#9 /var/www/x2engine/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#10 /var/www/x2engine/protected/controllers/x2base.php(578): CFilterChain->run()
#11 /var/www/x2engine/framework/web/filters/CInlineFilter.php(58): x2base->filterSetPortlets(Object(CFilterChain))
#12 /var/www/x2engine/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#13 /var/www/x2engine/protected/controllers/x2base.php(578): CFilterChain->run()
#14 /var/www/x2engine/framework/web/filters/CInlineFilter.php(58): x2base->filterSetPortlets(Object(CFilterChain))
#15 /var/www/x2engine/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))
#16 /var/www/x2engine/framework/web/filters/CFilter.php(40): CFilterChain->run()
#17 /var/www/x2engine/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))
#18 /var/www/x2engine/framework/web/filters/CFilter.php(40): CFilterChain->run()
#19 /var/www/x2engine/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))
#20 /var/www/x2engine/framework/web/CController.php(291): CFilterChain->run()
#21 /var/www/x2engine/framework/web/CController.php(265): CController->runActionWithFilters(Object(CInlineAction), Array)
#22 /var/www/x2engine/framework/web/CWebApplication.php(282): CController->run('login')
#23 /var/www/x2engine/framework/web/CWebApplication.php(141): CWebApplication->runController('site/login')
#24 /var/www/x2engine/framework/base/CApplication.php(185): CWebApplication->processRequest()
#25 /var/www/x2engine/index.php(64): CApplication->run()
#26 {main}X2Engine Version:  6.9
PHP Version:  7.0.30
Link to post
Share on other sites

This problem doesn't seem to occur in a stable environment. My guess is it's because I was playing around in Docker and using a MariaDB container, which was probably causing the database to become corrupt after some time.

 

This is why we don't run production DBs in containers! Please mark as solved. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...