Jump to content


Photo

Failed to Open IMAP Configuration

email imap cerrtificate

  • Please log in to reply
5 replies to this topic

#1 juddra

juddra

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 21 May 2018 - 10:32 AM

 I recently added ssl certificates to the wcc-tech.com domain but when I try to access email from the X2CRM application, I get the following error:

Failed to open IMAP connection. Please check your email configuration and ensure that your email credentials are valid. The error given was:
Certificate failure for mail.wcc-tech.com: Server name does not match certificate: /OU=Domain Control Validated/OU=PositiveSSL/CN=md-34.webhostbox.net
-Configure your personal email inbox-

Any help in sorting this out is appreciated.



#2 JacobD

JacobD

    Member

  • Members
  • PipPip
  • 14 posts

Posted 25 May 2018 - 10:55 AM

Yes. Bump! This is a problem to date. Can someone please address this? I am trying out different CRM solutions and without this bug being fixed, I will have to go elsewhere.



#3 Noime

Noime

    Member

  • Members
  • PipPip
  • 21 posts

Posted 25 May 2018 - 10:11 PM

You can disable the SSL verification check for the moment, emails will still be delivered over the encrypted channel.

 

But your problem stems from a misconfigured SSL, which is not within the hands of X2.

 

You want to authenticate wcc-tech.com when the associated SSL cert belongs to md-34.webhostbox.net - you may want to talk to some tech guy from your hosting company about this.

 

Again, this is nothing X2 can solve for you.



#4 Noime

Noime

    Member

  • Members
  • PipPip
  • 21 posts

Posted 25 May 2018 - 10:23 PM

For the fun, and to demonstrate what happens. I wanted to connect to wcc-tech.com, this translates to IP 199.79.62.13, but the server announced himself as 220-md-34.webhostbox.net.

Transcript: Connecting to 199.79.62.13 

Transcript: 

Transcript: 220-md-34.webhostbox.net ESMTP Exim 4.89 #1 Sat, 26 May 2018 06:16:34 +0000 

Transcript: 220-We do not authorize the use of this system to transport unsolicited, 

Transcript: 220 and/or bulk e-mail. [5710 ms] 


#5 JacobD

JacobD

    Member

  • Members
  • PipPip
  • 14 posts

Posted 30 May 2018 - 07:17 AM

Not to hijack this thread but when I said that the problem was still persisting it is because I believed that it was a bug in the X2crm software. I am not associated with the OP or wcc-tech.com but I am also having the problem on my domain when I had correctly configured ssl. Also, with ssl verification check disabled I am still receiving the same error which leads me to believe that there is some kind of bug. Is there anything more I should try to narrow down the source of the problem or am I just going to have to wait for a patch to fix this issue?


  • gfl likes this

#6 X2Peter

X2Peter

    Advanced Member

  • Administrators
  • 75 posts

Posted 09 January 2019 - 04:37 PM

Hello Juddra,

 

Noime is correct in asserting that there is a misconfiguration within your SSL certificate for your mail server. The CN (common name) for your certificate is set to md-34.webhostbox.net whereas your mail server is presenting itself as mail.wcc-tech.com. The CN must match the hostname of the server for IMAP to connect over SSL. This is normal behavior and not a bug. You will most likely need to generate a new certificate with a common name of mail.wcc-tech.com.







Also tagged with one or more of these keywords: email, imap cerrtificate

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users