Jump to content


Photo

What PHP Modules are required to install/run X2CRM

php modules required

  • Please log in to reply
4 replies to this topic

#1 sstarr01

sstarr01

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 15 April 2018 - 07:08 PM

Hi Everyone,

 

Can you let me know what PHP modules are required to install/run X2CRM? and what php.ini settings are required?

 

Installation reports no errors (I am using the Softaculous script) - When Try to access the home page, post installation, i get a HTTP 500 Error.

 

I have tried this on two separate hosting accounts (on the same WHM server) and both fail..... I have also tried the installation on a third hosting account on a different WHM server and that works fine.... The only thing I can think of is that the two platforms may have different PHP Modules enabled and different php.ini settings.

 

Both platforms are running with PHP 7.0 installed and I have given both 2048MB max memory and 1024MB post/upload size etc.

 

I enabled the php debug in the failing hosts and get the following output if that helps.

 

Thanks,

Steve.

 

Fatal error: Uncaught Error: Call to a member function getId() on null in /home/comslincrm/public_html/protected/models/Profile.php:687 Stack trace:

#0 /home/comslincrm/public_html/protected/controllers/x2base.php(576): Profile::getWidgets()

#1 /home/comslincrm/public_html/framework/web/filters/CInlineFilter.php(58): x2base->filterSetPortlets(Object(CFilterChain))

#2 /home/comslincrm/public_html/framework/web/filters/CFilterChain.php(130): CInlineFilter->filter(Object(CFilterChain))

#3 /home/comslincrm/public_html/framework/web/filters/CFilter.php(40): CFilterChain->run()

#4 /home/comslincrm/public_html/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))

#5 /home/comslincrm/public_html/framework/web/filters/CFilter.php(40): CFilterChain->run()

#6 /home/comslincrm/public_html/framework/web/filters/CFilterChain.php(130): CFilter->filter(Object(CFilterChain))

#7 /home/comslincrm/public_html/framework/web/CController.php(291): CFilterChain->run()

#8 /home/comslincrm/public_html/framework/web/CCo in /home/comslincrm/public_html/protected/models/Profile.php on line 687

 



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 325 posts
  • LocationGermany

Posted 15 April 2018 - 11:18 PM

Hi Steve

 

I´m also on PHP 7.0 - without any problem. May you want try to increase the MAX INPUT VARIABLES (I´ve choosen 5000) and adjust MAX INPUT TIME to a higher amount?



#3 sstarr01

sstarr01

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 April 2018 - 08:19 AM

Hi Alt_F4,

 

Thanks for the input, I have added the contents of my php.ini file below.

 

I changed the max_input_vars to 5,000 bu the same issue exists. 

 

When I open the web page, the browser waits (spinning loading icon) for about 5 seconds then displays the HTTP 500 error 

 

php.ini contents
display_errors = On
max_execution_time = 3000
max_input_time = 6000
max_input_vars = 5000
memory_limit = 2048M
post_max_size = 1024M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php70"
upload_max_filesize = 1024M
zlib.output_compression = Off


#4 sstarr01

sstarr01

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 16 April 2018 - 08:43 AM

Hi Everyone,

 

I have solved the issue, so sharing the solution......

 

I had to modify the php.ini file for the WHM server that the cPanel host sits on.

 

In the php.ini file I had, at line 305, the following:

disable_functions = "show_source, system, shell_exec, passthru, phpinfo, popen, proc_open, ini_set"

 

I removed the "ini_set" from the disable functions line:

disable_functions = "show_source, system, shell_exec, passthru, phpinfo, popen, proc_open"

 
Now both the failing installation show the login screen.
 
Thanks,
Steve.

 

 



#5 joeldeteves

joeldeteves

    Member

  • Members
  • PipPip
  • 15 posts
  • LocationVancouver, British Columbia

Posted 17 June 2018 - 03:56 PM

Here's what I needed to get it working on PHP 7:

  • ssh2-1.1.2 (via pecl)
  • imap (w/ kerberos + ssl)
  • mbstring
  • zip
  • gd
  • mcrypt
  • mysqli
  • pdo_mysql





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users