Jump to content


Photo

Filter text re-appears in Chrome in gridview

filter chrome bug

  • Please log in to reply
16 replies to this topic

#1 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 27 March 2018 - 02:08 AM

Hi guys,

 

I have a weird issue.

 

On our one machine, using Chrome, if I go to a module and see grid-view of records, in the ID field column filter box, text appears for no reason to filter. The text in this filter is from an old filter exercise and has nothing to do with the ID field even.

 

The net result is that the grid-view then filters and obviously doesn't show anything.

 

I have cleared Chrome cache, cookies and all. On that machine if I log into the instance as other users it does the same in Chrome.

 

On the same machine using another browser its doesn't do it. Also on other machines, not the issue also. It seems to be one machine with that one Chrome.

 

Any idea how to fix it?

Attached Thumbnails

  • 2018-03-27 (1).png
  • 2018-03-27 (2).png
  • 2018-03-27 (3).png


#2 medotron

medotron

    Advanced Member

  • Members
  • PipPipPip
  • 73 posts

Posted 29 March 2018 - 04:52 PM

maybe chrome auto-fill issue?

 

 

Hi guys,

 

I have a weird issue.

 

On our one machine, using Chrome, if I go to a module and see grid-view of records, in the ID field column filter box, text appears for no reason to filter. The text in this filter is from an old filter exercise and has nothing to do with the ID field even.

 

The net result is that the grid-view then filters and obviously doesn't show anything.

 

I have cleared Chrome cache, cookies and all. On that machine if I log into the instance as other users it does the same in Chrome.

 

On the same machine using another browser its doesn't do it. Also on other machines, not the issue also. It seems to be one machine with that one Chrome.

 

Any idea how to fix it?



#3 Attila

Attila

    Advanced Member

  • Members
  • PipPipPip
  • 60 posts
  • LocationJohannesburg, South Africa

Posted 29 March 2018 - 11:27 PM

I have the same thing as of a week ago, Im getting usernames getting inserted into the email filter field. 

 

It does not happen with Internet Explorer

 

see below (ignore the red arrow)

Attached Thumbnails

  • Capture.PNG

Never allow waiting to become a habit. Live your dreams & take risks. Life is happening NOW !


#4 X2Peter

X2Peter

    Member

  • Administrators
  • 19 posts

Posted 04 April 2018 - 03:33 PM

Hey Guys,

 

It appears that this may be a browser issue, we are looking at a few different ways to prevent the auto-fill for unnecessary fields. I will bump this thread with updates as soon as we come to a conclusion.



#5 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 05 April 2018 - 03:55 AM

Thanks for the update on this. I will inform my client also.

 

Cheers



#6 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 06 April 2018 - 01:03 AM

Is there any work around for this issue. For now with the persistent filter being put in, you cant work on gridview.



#7 fastfreddie

fastfreddie

    Member

  • Members
  • PipPip
  • 28 posts

Posted 11 April 2018 - 06:52 AM

Adding my voice to this. We have the same problem for more than one user. A fix would be very welcome. We're using Chrome.



#8 poborn

poborn

    Member

  • Members
  • PipPip
  • 17 posts

Posted 18 April 2018 - 04:42 PM

Same

This started happening a couple of weeks ago on one PC. Now happening on two PCs.

Only happening in the email address column.



#9 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 286 posts
  • LocationGermany

Posted 22 April 2018 - 09:43 PM

The autofill-/password-manager of Chrome seems not to be able to distungish between login and other fileds.

 

May an additional <form autocomplete="off"> for all the sort-fileds could resolve the issue?



#10 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 22 April 2018 - 10:53 PM

AltF4 are you sure thats the Chrome issue? If so its great to have found the source!

 

[WORK-AROUND] Our work-around involves one of mutliples of the following: 

  • X2CRM Clear filter button toggle,
  • alternative is clearing browser data and cookies and
  • start using Incognito or
  • another browser.

But would be great if it van be solved.



#11 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 286 posts
  • LocationGermany

Posted 23 April 2018 - 10:26 PM

Chrome (v66): I´ve to clear my auto-fill fields for X2.domain

Firefox/Edge: works like a charm without an issue

 

So I guess the autofills in Chrome are interpreted in another way than FF/Edge does.



#12 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 08 May 2018 - 11:45 PM

Hi AltF4,

 

how do you mean you clear autofill for the fields or the URL. Do you turn autofill completely off? Cant see where chrome uses autofill per domain or specific field. Also cant see how that can relate to random field headings in the gridview.

 

Please elaborate as this bug is serious disabling the X2 base functions

 

Thanks



#13 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 286 posts
  • LocationGermany

Posted 10 May 2018 - 12:55 AM

Hi Eugene,

 

my given answer was imprecise. You´ve to delete your saved passwords (only) for your used X2.domain, see https://support.goog...m=Desktop&hl=en--> 

 

 

You can delete passwords at any time:

 
  1. At the top right, click More More and then Settings.
  2. At the bottom, click Advanced.
  3. Under "Passwords and forms," click Manage passwords.
  4. Delete: To the right of the website, click More More and then Remove.


#14 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 14 May 2018 - 12:49 AM

Hi Alt+F4,

 

seems you are onto something. It works for me since last week. Havent had the problem for a week now. Maybe its the Google vault from the previous browser version to the new upgrade that doesnt work. But clearing the password of that domain have stopped it for now.

 

Thanks a mil. Will keep monitoring.



#15 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 15 May 2018 - 08:15 AM

[CONFIRMED BUG]

 

Guys I have done extensive testing with Alt+F4's advice (above) and can confirm this bug is based on the chrome saved password for the domain where X2 is hosted. If a password is saved for that specific instance of the domain where X2 is, it autofills the gridview. Passwords saved for other domains dont have a influence. As well as other X2 instances in your browser password list. But passwords for the URL instance you work on, the bug appears.

 

X2, do you guys have a solution maybe yet?

 

Thanks Alt+F4



#16 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 261 posts
  • LocationCenturion, south Africa

Posted 04 July 2018 - 08:32 AM

Hi X2 guys,

 

I just want to ad some weight to this issue. Although we found a work around as above, by never saving your username and password for your site, it is creating serious mistrust in the software due to the impact it has on users. 

 

We found that users do not know the work around and as normal users, can't fix it themselves. The nature of the bug means that if you look at your grid-view, it seems your records are gone or you simply can't reach your records because the bug places your login details into the filter field, thus constantly filtering your records and not showing any records then.

 

As far as I could I informed my user-base of this bug and how to fix it. Problem are users aren't that accommodating when they cant use the basic interface.

 

Any fix yet maybe?

 

Thanks



#17 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 286 posts
  • LocationGermany

Posted 04 July 2018 - 10:04 PM

+1 for the post above. A fix would be very welcome.







Also tagged with one or more of these keywords: filter, chrome, bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users