Jump to content


Photo

Cannot add records after new install

Cannot add records

  • Please log in to reply
10 replies to this topic

#1 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 August 2017 - 05:23 AM

I have just installed a fresh copy of 6.9 and I am unable to add any records to any module.

I also notice that the interface appears to be overlapping in places as if the theme is broken.

I tried changing the theme to correct this but this also does not work.

I also noticed that when I move my mouse over many of the buttons such as the select columns button on the list view I notice the javascript:void(0) message at the bottom left of the screen.

This has me stumped?



#2 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 17 August 2017 - 05:42 AM

I have also checked the logs and get this error:

Uncaught TypeError: x2.Forms is not a constructor at index:2169


#3 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 102 posts

Posted 17 August 2017 - 09:07 AM

Hey troyferraris,

 

Does an error appear when you try to add a record? Check the console as well to see if it could be a possible javascript error.

 

Also check if it works in a private browser.

 

And send a screenshot of the broken theme that you were mentioning.

 

Cheers



#4 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2017 - 08:38 PM

I have also been able to solve some of the errors by renaming files as I see that the code calls for file names are not the same case as the files itself. By changing the case, e.g. X2forms.js to X2Forms.js some of the errors went away. I wonder if case sensitivity is the problem here?



#5 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2017 - 10:47 PM

Here is a screen capture. As you can see the central frame is cut off on the left.

Also see the search bar at the top right.

Attached Files



#6 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 20 August 2017 - 11:06 PM

I just noticed that the records are actually being added, I just cannot see them.

So this looks like a view/graphic problem.

I have attached a screen capture where you can see there are 4 records but they cannot be displayed.

 

Attached Files



#7 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 21 August 2017 - 03:22 AM

I also keep getting this error:

Uncaught TypeError: x2.Forms is not a constructor



#8 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 102 posts

Posted 21 August 2017 - 09:21 AM

Hey troyferraris,

 

Glad you were able to solve some of your issues. Hm that is interesting how that its behaving like that, did you install 6.9 from sourceforge? and what browser are you using? the browser may also play a part in the displaying the records incorrectly



#9 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 21 August 2017 - 08:22 PM

I installed it using Softaculous from my CPanel. I have tried multiple browsers with the same result.

I also tried installing it on a second server where I currently have version 5.3.1 running perfectly and I got the same result.



#10 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 102 posts

Posted 22 August 2017 - 09:42 AM

Hey troyferraris,

 

We are planning to update to the Github soon with the new 6.9 update, which should in turn update softaculous's package as well in order to fix the issues you are running into.

 

I would recommend waiting a little while for the update to push, or to install from our github currently and then updating manually, or installing through sourceforge directly.

 

Also, what OS are you installing on?



#11 troyferraris

troyferraris

    Member

  • Members
  • PipPip
  • 10 posts

Posted 24 August 2017 - 12:40 AM

Thanks, we are running Linux on the servers. I am very happy with the current 5.3.1 we are running and will rather wait for the next update as I definitely want to stay with the product and upgrade to the new version if it will work.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users