Jump to content
X2Community Forums

Unable to Update from 6.0 to 6.9


Recommended Posts

Using php 5.5.

 

First thing necessary was adding the ssh2 module, which I did through CPanel.

 

Uploaded the requirements.php file and it says:

This webserver can run X2Engine!

But the updater still says Cannot run updater.

One or more dependencies of AdminController are missing and could not be automatically retrieved. 
They are protected/views/admin/updater.php, protected/components/UpdaterBehavior.php

Both of those files exist on the server, with permissions -rw-r--r-- and owned by myself, as are the rest of the files.

 

The error is most likely due to one of the following things:

  • DOUBTFUL, BUT CHECKING WITH ADMINS:
  •           (1) PHP processes run by the web server do not have permission to create or modify files
  • (2) x2planet.com and raw.github.com are currently unavailable
  • BOTH SEEM TO BE RUNNING, ALTHOUGH x2planet.com IS FORBIDDEN
  • (3) This web server has no outbound internet connection. This could be because it is behind a firewall that does not permit outbound connections, operating within a private network with broken domain name resolution, or with no outbound route.
  • I’M USING CLOUDFLARE, BUT AS FAR AS I CAN SEE THE SITE IS MAKING OUTBOUND CONNECTIONS VIA HTTP

 

To stop this error from occurring, if the problem persists, restore the file protected/controllers/AdminController.php to the copy from your version of X2Engine:

https://raw.github.com/X2Engine/X2Engine/6.0/x2engine/protected/controllers/AdminController.php

          THIS FILE MATCHES THE LOCAL ONE, at least it's copyright is 2016, whereas the new one has 2017.

 

Not sure where else to poke at this point.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Hey MikeiLL,

 

This has been an issue before, what I would suggest first is to back up your instance and database.

 

Then, I would check to see if your web server can make outbound connections to the updater url for X2Planet. If you get a 403, that should be fine.

Make sure all of the files in your installation have both read and write access for the web server.

 

I would then try to run the update again on the web interface. If that does not work, try to update from the command line with

./yiic update app

while in the protected/ directory.

 

Let me know if this helps.

Link to post
Share on other sites
  • 2 weeks later...

Hi and thanks. When you say make outbound requests to the updater URL do you mean for example:

wget https://x2planet.com/installs/requirements.php

What exactly IS the "updater url for X2Planet"?

 

As of right now, when I run `./yiic update app` I get the same error:

 

 

One or more dependencies of AdminController are missing and could not be automatically retrieved. They are protected/views/admin/updater.php, protected/components/UpdaterBehavior.php

 

Both of those files exist with 644 permissions. (Tried with 755 permissions as well.)

  • Like 1
Link to post
Share on other sites

Hm. Actually, since your version of X2 is pretty outdated, we can try updating the updater package since it is not recognizing your updater files. This would also be considered an offline update.

 

First, you would download the updater files from this url:

 

https://x2planet.com/installs/updater.zip

 

Then, you would extract the zip and upload the protected/ directory in the zip to the protected/ directory in your instance, essentially merging them.

 

Then, in protected/config/X2Config.php, change your updater version to the one found in this link.

From there, make sure the web server has access to all your files, and then you can try to update like normal, through either web interface or the manual command I mentioned in a previous post.

 

More information can be found in this link, which gives step by step instructions for more clarification. If this does not work, try the other options listed below the one I have mentioned. Remember to backup your instance as well in case of error.

Link to post
Share on other sites
  • 2 weeks later...

Thank you so much, Isaiah. Success.

 

I updated the protected dir with rsync:

rsync -avP local_unzipped_protected user@server.com:public_html/outreach/protected

I wasn't able to run `./yiic update app` with `644` permissions so changed to `755`.

 

Secure enough to leave 755 permissions on `yiic`?

 

Also configured `index.php/admin/updaterSettings` for automatic updates and ran

# /home/user/public_html/outreach/protected/yiic update app --lock=1 
The updater is up-to-date and safe to use.
X2Engine is at the latest version!
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...