Jump to content


Photo

Safari browser issues


  • Please log in to reply
3 replies to this topic

#1 mcrt

mcrt

    Member

  • Members
  • PipPip
  • 22 posts

Posted 09 August 2017 - 08:03 AM

Is anyone else having issues with X2 with the Safari browser on macOS?  We just upgraded to X2 v6.9 from v5.4.3 and it seems none of the javascript is working on the dashboard.  Activity feed isn't dynamically updated, filter controls can't be applied, etc.

 

Just to make sure it isn't an issue with our customizations, I also tested the on the live demo server with the same results.

 

I have tried clearing all the cookies, history, and restarting Safari but no change.  Everything works fine when tested with Chrome.



#2 X2Josef

X2Josef

    Member

  • Moderators
  • 12 posts

Posted 09 August 2017 - 10:15 AM

Hi mcrt,

 

Have you already checked if javascript is enabled under Safari's Preferences -> Security tab?



#3 mcrt

mcrt

    Member

  • Members
  • PipPip
  • 22 posts

Posted 09 August 2017 - 10:32 AM

Hi mcrt,

 

Have you already checked if javascript is enabled under Safari's Preferences -> Security tab?

 

Hi Josef,

 

Yup, javascript is enabled under Safari's preferences.  Does it work for you with Safari (uncheck filters button & deleting activity from the dashboard view)?



#4 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 66 posts

Posted 10 August 2017 - 09:16 AM

Hey mcrt,

 

This seems to be a bug that we have not accounted for. Thanks for letting us know and we will try to get this working in upcoming updates!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users