Jump to content


Photo

Installalling into a VM

staff response

  • Please log in to reply
5 replies to this topic

#1 chrismsa

chrismsa

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 July 2017 - 12:46 AM

Hi All

 

Pretty much a newbie at this. I have a VM in esxi 5.5 running ubuntu 16.04. I install x2crm without any issues & can login & do waht I want. However if I shutdown & restart the VM nothing works & I have to reinstall x2crm. Any help appreciated.

 

Regards

 

Chris



#2 chrismsa

chrismsa

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 04 July 2017 - 04:23 AM

Anyone ??



#3 X2Raymond

X2Raymond

    Advanced Member

  • Administrators
  • 972 posts
  • LocationSanta Cruz, CA

Posted 05 July 2017 - 08:01 AM

Hello Chris,

 

Could you please describe how the VM behaves after you restart it? Can you reach the web server at all, or does the request fail or timeout? You may want to verify that ports 80 and 443 are available through the firewall. If you're still using UFW on Ubuntu, you can verify your firewall rules with:

sudo ufw status numbered

After rebooting, you can also check whether Apache was properly started with the commands:

ps aux | grep apache
netstat -tln | grep :80

If it is not running, but you can start it with "service apache2 start", then it may not be enabled at runtime. In this case, you can re-enable the service with:

update-rc.d apache2 defaults

You may also be interested in our wiki article "Preparing a Linux Server Environment," which covers many aspects of hosting X2CRM on a Linux server: http://wiki.x2crm.co...ver_Environment

 

Raymond



#4 chrismsa

chrismsa

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 05 July 2017 - 10:04 PM

Hi Raymond

ufw is inactive ; ps -aux | grep apache returns a pid ; netstat -tln | brep 80 returns nothing; running update-rc.d apache2 defaults does nothing



#5 chrismsa

chrismsa

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 05 July 2017 - 11:29 PM

Raymond - The vm behaves normally - no errors at all.



#6 X2Raymond

X2Raymond

    Advanced Member

  • Administrators
  • 972 posts
  • LocationSanta Cruz, CA

Posted 06 July 2017 - 11:44 AM

Ah interesting, perhaps plain HTTP is disabled, how about:

netstat -tln | grep :443

If this returns an open port, try to reach your instance by prefixing https:// in front of your VM IP address or domain name.

 

You'll also want to check your Apache error log at /var/log/apache2/error.log for anything interesting.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users