Jump to content


Photo

Calendar empty

staff response

  • Please log in to reply
12 replies to this topic

#1 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 15 January 2017 - 03:00 PM

Hi again,

I have connected my user account to Google. 

I have created one calendar and connected to google calendar.

The calendar is empty. If I create an appointment in the log it is created but calendar stays empty.

I have checked the checkbox on calendar list but nothing changed.

If I try to create a calendar without connecting to a google calendar there is an error and x2crm offers me to open a bug report (I have done it).

 

Thanks again for help,

Mario



#2 ToanLuong

ToanLuong

    Member

  • Members
  • PipPip
  • 23 posts

Posted 16 January 2017 - 01:15 AM

Do you follow this instruction in Google Integration?

 

  1. Visit https://console.developers.google.com and create or select a Google project.
  2. To configure Google integration for Calendar sync, Google login, and Google Drive access:
    1. From the "APIs & auth" section in the left sidebar, select "APIs."
    2. Search for and enable the following APIs:
      1. CalDav API
      2. Google Calendar API
      3. Google Drive API
    3. From the "APIs & auth" section in the left sidebar, select "Credentials."
    4. Create an OAuth 2.0 client ID.
    5. When asked for "Authorized Redirect URIs," input the following urls:
    6. When asked for "Authorized JavaScript Origins," input the following urls:
    7. Copy the Client ID and Client Secret into OAuth 2.0 Credentials section below.
  3. To configure Google integration for the Google+ and Google Maps widgets:
    1. From the "APIs & auth" section in the left sidebar, select "APIs."
    2. Search for and enable following APIs.
      1. Google Maps Geocoding API
      2. Google Maps Directions API
      3. Google Static Maps API
      4. Google Maps JavaScript API
      5. Google+ API
    3. From the "APIs & auth" section in the left sidebar, select "Credentials."
    4. Create an API key.
    5. When asked for key type, select "Server key."
    6. Copy the API key into the Google+ and Google Maps Integration section below.


#3 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 19 January 2017 - 03:52 AM

Yes sure!

And I can ask: where should I start the integration procedure:

1) from admin/emailconfiguration/google integration

or

2) from admin (on the right) / manage apps/ add new

 

?

 

Thanks,

Mario

PS: is 6.5.3 with bug fixes coming out soon?



#4 X2Raymond

X2Raymond

    Advanced Member

  • Administrators
  • 972 posts
  • LocationSanta Cruz, CA

Posted 19 January 2017 - 10:55 AM

You can start configuring Google Integration through either method. When configuring the integration through the manage apps page, it must be performed as the administrator. Based on the errors you encountered in calendar setup, it sounds like the integration may not be fully or successfully configured, as it's failing to fetch the remote calendars. You might want to try disabling/reenabling the integration.

 

And yes that's correct, 6.5.3 is on the way in another two weeks or so.



#5 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 21 January 2017 - 03:13 AM

I have tried to redo google integration from scratch. I have double checked api and recreated maps key.

Disabled and reenabled integration.

Now unfortunately I cannot login anymore with google, it hangs at "logging you in..." after saying "welcome back Mario".



#6 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 21 January 2017 - 04:27 AM

Can I enable a log?



#7 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 03 August 2017 - 12:49 AM

I have installed latest version. I have the same problem: I cannot login anymore using google the login procedure hangs forever.

Please help me tell me how I can debug it.



#8 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 161 posts

Posted 03 August 2017 - 09:25 AM

Hey mgiammarco,

 

Is the general X2CRM login or the Google integration setup taking forever?


Isaiah Solomon

Software Engineer

X2Engine Inc.


#9 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 04 August 2017 - 11:39 AM

The Google integration setup, after trying to redo it from scratch.



#10 X2Isaiah

X2Isaiah

    Advanced Member

  • Moderators
  • 161 posts

Posted 04 August 2017 - 12:09 PM

Hm I was not able to recreate the same error. A couple things I would suggest to further debug your issue:

 

1. Check your browser's console and see if any javascript errors are appearing when you try to log in

2. In your browser's console, also check the network tab to see if any errors are appearing there as well

3. Make sure you are following the set up instructions correctly word for word (the previous comment on this thread, the instructions on the google integration page for setting up Oauth2.0)

4. When you input the urls for "Authorized Redirect URIs", make sure you are inputting each url separately

5. Make sure you are updated to the latest version 6.9

 

Let me know if any of those work, and we can further try to see where the issue could be.


Isaiah Solomon

Software Engineer

X2Engine Inc.


#11 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 05 August 2017 - 06:48 AM

I have found something interesting in javascript console:

 

VM1992:1 POST http://crm.giammar.i...site/storeToken500 (Internal Server Error)

 

 



#12 mgiammarco

mgiammarco

    Member

  • Members
  • PipPip
  • 23 posts

Posted 20 August 2017 - 12:14 PM

Can you help me with this log message?



#13 cobaltor

cobaltor

    Newbie

  • Members
  • Pip
  • 8 posts
  • LocationSicily, Qatar

Posted 01 September 2017 - 06:57 AM

Hello,

me also have same Issue. I can see Calendar Event on Activity feed but on Calendar page.







Also tagged with one or more of these keywords: staff response

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users