Jump to content


Photo

"File is too big. Max filesize: 2MiB."

file size big 2mb 2mib

  • Please log in to reply
2 replies to this topic

#1 wut

wut

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 October 2015 - 10:41 AM

Hello! I have had my hosting company try to resolve this issue for me and they couldn't help. I've looked through quite a bit of the code trying to find something that dictates this "2MiB" limit. Haven't been successful. My host said the best way to resolve this was to reach out to the developers.

 

I have my upload_max_filesize set to 10M in my PHP Configuration. I'm able to upload any other file, as long as it's under 2Mib.

 

You can see the picture attached as reference to what error I get. Is anyone else having this issue? Everything else in x2 works great!

Attached Files



#2 alt_f4

alt_f4

    Advanced Member

  • Premium Members
  • PipPipPip
  • 389 posts
  • LocationGermany

Posted 04 October 2015 - 11:37 PM

Let your hoster edit your configuration file (php.ini) again, there are two settings:
 
upload_max_filesize = 10M
post_max_size = 10M
 
Regards!


#3 X2Derek

X2Derek

    Advanced Member

  • Administrators
  • 443 posts

Posted 05 October 2015 - 12:15 PM

Hi wut,

 

This issue is the result of a bug in the media upload widget affecting versions 5.2 and 5.2.1. The widget will limit uploads to 2MB regardless of your server settings. The bug has been fixed for the upcoming 5.2.2 update, which should become available this week.

 

If you wanted to apply a temporary fix, there's a one line change you can make to js/FileUploader.js to increase the widget's upload limit. In 5.2.1 opensource edition, the line responsible for the upload limit is 117, in Professional and Platinum edition, it's line 103.

 

Derek







Also tagged with one or more of these keywords: file, size, big, 2mb, 2mib

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users