Jump to content


Photo

Activity Feed not showing for Roles

Activity feed issue roles

  • Please log in to reply
5 replies to this topic

#1 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 355 posts
  • LocationCenturion, south Africa

Posted 15 June 2015 - 06:58 AM

Hi guys,

 

I am a bit stumped. I have setup X2 (Premium) with various roles. I have in detail setup Manage Roles per field as well as Edit Access Rules to limit access to modules and any records outside of Assigned To the indicated user. Activity Feed is usable and visible to all roles.

 

However, any of my users can communicate to Admin via Activity by posting in their own feed, assign to Admin. The admin gets notification 'boing' and it shows immediately in the Admin feed. Works great.

 

However, not the other way around. Admin or for that matter anyone sending to a User in a role doesn't work. The recipient user gets his 'boing' notification and it shows "xxx" posted on your feed. But no where is the post visible.

 

It must be some of the rights linked to the feed that I disabled. I cant however see anywhere settings to give visibility and edit rights to Activity Feeds.

 

Please help on this.

 

Thanks

 

Eugene

Attached Files



#2 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 355 posts
  • LocationCenturion, south Africa

Posted 15 June 2015 - 07:44 AM

If I change the role of the sender to global admin the activity feeds show all. Thus it seems to be something todo with the roles, users, access rights not allowing any activity feeds other than your own to show.

 

Suggestions?

 

Thanks



#3 X2Derek

X2Derek

    Advanced Member

  • Administrators
  • 443 posts

Posted 15 June 2015 - 02:40 PM

Hi Eugene,

 

You might be using a restrictive Activity Feed privacy setting. Feed privacy settings can be configured from the General Settings admin page:

Attached File  feedPrivacy.png   16.7KB   1 downloads

 

Derek

 



#4 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 355 posts
  • LocationCenturion, south Africa

Posted 16 June 2015 - 02:37 AM

Thanks Derek,

 

that was definitely the setting I missed. 

 

But playing with it I cant seem to get it working right. Either everyone sees everything or activities marked private doesn't show at the recipient although it "boing' notifies. I tried every combination from global setting being default, group or user.

 

My scenario is I have a Franchisor (Office)  and lots of franchisees Fran01, Fran02 etc. the Office needs to sometimes announce to all, but sometimes send a private message to the user (Fran01 etc).

 

I have created lots of scenarios by grouping them all, creating small groups between Office and each franchise etc.

 

It seems as soon as a message is marked private the recipient doesn't show the message.

 

Boiling down to all messages on each scenario being group, user or default is public and on everyone activity as private messages cant be seen.

 

Any suggestions or am I missing a setting maybe on the user level?

 

Thanks



#5 X2Derek

X2Derek

    Advanced Member

  • Administrators
  • 443 posts

Posted 16 June 2015 - 12:15 PM

Hi eugeneb,

 

There's a bug in 5.0.8 which prevents non-admin users from seeing private messages that they didn't personally author. This has been fixed for version 5.0.9, which will hopefully be available next week.

 

Derek



#6 eugeneb

eugeneb

    Advanced Member

  • Members
  • PipPipPip
  • 355 posts
  • LocationCenturion, south Africa

Posted 17 June 2015 - 08:53 AM

Awesome. Thanks.

 

Definitely something we need to get sorted as we have our users communicating quite a lot and privacy has been a issue.

 

Thanks for a brilliant piece of work... :D







Also tagged with one or more of these keywords: Activity, feed, issue, roles

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users