Jump to content
X2Community Forums

Recommended Posts

Hi m.dhouibi,

 

I assume that you're trying to set the public base URI, but can't because the base URL fails validation. Is that correct? Unfortunately, if you're hosted locally, the base URL field auto-populates with "http://localhost"which isn't valid. We'll fix this for our next release. In the meantime, if you wanted to set the public base URI, a workaround would be to clear the base URL field before saving.

 

Derek

  • Like 1
Link to post
Share on other sites
  • 8 months later...

This validation is currently rejecting 'localhost' based on the default regex pattern for Yii's CUrlValidator, which requires the top level domain to be specified. 'localhost' is also an invalid entry for the external base URL, as it is used in rendering links for external facing resources and the links rendered will never work for anyone who receives them, instead resolving to their localhost. However, while you are configuring your email settings, you can temporarily set the external base URL to 127.0.0.1, but once you are ready for production, I'd recommend ensuring your external base URL is set to a publicly accessible domain.

 

Raymond

Link to post
Share on other sites
  • 5 years later...

Hello, I need help I am getting the same error when i try to click on "Save" error is"  

Please fix the following input errors: External / Public Base URL is not a valid URL. , There is no field for base URL in this form how can i fix it?? please help me ASAP.

Thank you,

Belqes

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...