Jump to content
X2Community Forums

Recommended Posts

I wasn't able to reproduce this bug in 4.3b in either of those browsers. If you open up your browser's JavaScript console (ctrl-shift-k in firefox or ctrl-shift-j in chrome) and then click the '[add]' button, does any error output get displayed?

Link to post
Share on other sites

Ah! Was getting 405 not allowed messages in the console. Permissions were wrong on a bunch of the .js files. Then there was an issue with CloudFlare permissions as well, so bypassing the X2 directory. Will report back when changes go into effect. Thank you.

Link to post
Share on other sites

Oh my west-coast brothers. Could you offer a clue as to where I might look to solve errors like:

 

Uncaught SyntaxError: Unexpected token ; lists:918
Uncaught ReferenceError: yii is not defined

Uncaught SyntaxError: Unexpected token ; index:1253
Uncaught TypeError: Cannot read property 'translations' of undefined

 

Eternally grateful. Well grateful for a while anyway.

 

-iLL

Link to post
Share on other sites

It sounds like some of the dependencies aren't being loaded. You mentioned CloudFlare, how much are you serving from their CDN? Please ensure all of your assets are being published. If you'd like, you can PM me with more details of your method for pushing to the CDN so that I have a better idea of your situation.

 

Aside from that, it may be worthwhile to reinvestigate the permissions of your webroot. Ensure that the files are owned by the executing user. This is either set in your apache config (/etc/apache2/apache2.conf on Ubuntu/Debian) with a directive such as:

User raymond
Group raymond

or, by default on Debian and Ubuntu, it is set in a separate file, /etc/apache2/envvars such as:

export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data

If this is conflicting, you can use -R flag for chown to recursively set ownership on your webroot, like: `chown -R www-data:www-data`

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...