Jump to content
X2Community Forums

Recommended Posts

Hi,

I have X2 Open source installed in an A2Hosting account, and it was installed manually - no scriptaculous.
There is an update available, but when trying to run it I get this error:
 

Exception: "Requirements check script encountered an internal error. You should try running it manually by copying it from protected/components/views/requirements.php into the web root of your CRM. The error was as follows:file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 [2] : /home/(username)/public_html/x2/protected/components/views/requirements.php L401; Array" in /home/(username)/public_html/x2/protected/components/UpdaterBehavior.php L1393

 

If I upload a php.ini file enabling allow_url_fopen, I then start receiving this error:

 

Fatal error: Class 'PDO' not found in /home/(username)/public_html/x2/framework/db/CDbConnection.php on line 422

 

Please, can someone give me a light?

Thank and regards,
Arthur

Link to post
Share on other sites

Hello Arthur,

Can you confirm the function that is calling file_get_contents()? Or if you would like you can private message me the stack trace, or submit a bug report.

Did you attempt to run the requirements.php script from the CRM web root? If so, what was the result? Also, what version are you running?

Link to post
Share on other sites
  • 1 month later...

Hi, 

Thank you for your attention. Had to halt some activities for a while, so I had not seen your answers before. Sorry.

Today I've tried to update again (now it tries to update to v4.0), but it finds a problem in the first step (obtain and check data):

 

 

Errors encountered.
Could not complete operation because the request to the server failed or timed out. (parsererror undefined SyntaxError: Unexpected token <)

 

 

 

 

@X2Raymond: Sorry, I don't know. How can I find that out?

@x2demitri: I've replaced my requirements.php and tried it. This is what I get (PHP Version 5.3.27):

  • The PHP configuration option "allow_url_fopen" is disabled. CURL will be used for making all HTTP requests during updates.
  • Fileinfo: required but missing. Image previews and MIME info for uploaded files in the media module will not be available.
Severity legend: minor major critical 

All other essential requirements were met. 
Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...